
 
 
  
 
 
 

Using AutoCAD® Civil 3D® for Stormwater Management Tasks: 
Part I, Hydrology 
Dana Breig Probert, Engineered Efficiency  

CV314-2 This class will show you how to harness the power of AutoCAD Civil 3D 2008 to 
assist in designing and performing a TR-55/TR-20 or Rational Method Stormwater Management 
Analysis, including techniques for annotating plans, creating tables and preparing for modeling in 
your favorite hydrology software package. 
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Using AutoCAD® Civil 3D® for Stormwater Management Tasks: Part I, Hydrology 

While Civil 3D does not include an true set of hydrology tools, there are many ways to get the 
data you need for your modeling software. This class will explore some of those techniques. 

This class assumes: 

1. You are frustrated with how you currently prepare data in CAD for input into TR20, TR55 
or rational method analysis. 

2. You know that Civil 3D is built on a full version of Map 3D and a full version of AutoCAD. 
3. You understand that Civil 3D does not have any explicit hydrology tools, but there are 

lots of great Civil 3D and Map 3D tools that can be used to help you with your analysis. 
4. You are familiar with Civil 3D objects especially surfaces and parcels. 
5. You have a basic understanding of how to create Civil 3D labels. 
6. You are willing to spend some time learning how to create expressions in Civil 3D labels. 
7. You are willing to spend some time learning how to build Map Topologies, make Map 

Themes and create Map Annotation templates. 
8. You are willing to spend some time learning how to use AutoCAD tables within drawings 

and possibly linking them to MS Excel. 

√ Since Map tools are a skill gap for many civil users, I will be showing quick steps on how to set up 
topologies, themes and annotation templates live demo portion of this class. Additional information 
can be found in tutorials under the Help menu, AU classes, AUONLINE, skill builders and AOTC. My 
shortlist of highly recommended skills for civil users includes: attaching a drawing, creating queries, 
importing GIS data through Map>Tools>Import as well as through the FDO. 

Best Practices? 
What is best practice for me could be completely wrong for you. Conventional wisdom on the 
use of Civil 3D is constantly evolving. Many people don’t like sharing their best practices 
because any time you “stick your neck out” and show procedures you open yourself up for 
scrutiny and potential criticism. For me, I like to share information because it starts a dialog and 
encourages others to share their approach. The techniques in this presentation are intended to 
assist you in opening the Civil 3D bag of tricks and launch you on your own journey to 
discovering your own Best Practices. 

Much of work that is ongoing is documented on blogs like www.civil3d.com and the Autodesk 
discussion groups, so become a regular reader, and when you feel ready, a contributor. 



 
 
  
 
 

The Site 
Our example site is approximately 170 acres located on the Delmarva Peninsula. 

 

 

 

 

 

 

 

 

 

 

Analyzing Surface Elevations 
The Surface Elevation Analysis tool is useful for determining how water is moving across your 
site, where it is collecting and possible subcatchment delineations. 

 

 
To create an elevation analysis: 

1. Make sure you have an elevation analysis style that will show you what you need. 
2. Build a surface. 
3. Change the surface style to your elevation analysis style. 
4. “Crunch” the surface and make customizations on the Analysis tab of the Surface 

Properties dialog box. 



 
 
  
 
 
If the standard analysis ranges do not provide enough contrast, you can increase the number of 
elevation intervals. 

 

A Surface Elevation table can be customized to provide the proper look and information for your 
plan. 

 

Using Water Drop 
Surfaces>Utilities>Water Drop can help you determine how water will flow across your site and 
assist you in making judgments about time of concentration. 

 
 



 
 
  
 
 

 

Making Quick Profiles 
Quick profiles can help you learn more about the drainage nuances of your site. Right click on 
an object, or choose Profiles>Quick Profile. 

 
 

 



 
 
  
 
 

 

Multiple Quick Profiles can be used to asses your surface, and learn about channel flow. 

 

 

√ You might find it useful to split your model space into multiple viewports so that you can see what is 
happening in plan and profile at the same time. To split your viewport use View>Viewports>2 
Viewports. 

 



 
 
  
 
 
Simple Surface Visualization 
Surface visualization can assist the designer, the review agency and the client in understanding 
site drainage patterns for both existing and proposed ground. 

You can visualize the elevation analysis of the surface by changing the elevation analysis style 
to 3D faces. 

 

It often helps to exaggerate the triangle elevations when your site is relatively flat. 

 

Another thing you can do is to remove the isolines from the visual style.  This will make the 
surface easier to see in 3D. 

 

√ Visual styles are an AutoCAD feature. Read up on the AutoCAD visualization tools under help, or 
check out other AU classes on the subject. 



 
 
  
 
 
Rotate the surface into an isometric view and apply your visual style. 

 

 

Create a 3D DWF by typing 3DDWFPUBLISH in the command line and saving the resulting file.  
A DWF can be shared with non CAD users and provides an easy way to navigate your simple 
visualization. 

 

 



 
 
  
 
 
Labeling your Surface Slopes and Spot Elevations 
Surface slope and spot elevation labels can be customized to assist in labeling TC paths.  
Alternatively, you can use a set of alignment and profile labels for more powerful TC path 
analysis. 

 

Subcatchment Analysis and Curve Number Determination 
TR-55, TR-20, Rational Methods and other accepted forms of hydrologic analysis typically 
require the breakdown of our site into a series of areas that combine Drainage Area 
(Subcatchment), Soil Hydrologic Group, Cover Type and Cover Quality.  The delineation of 
these areas is time consuming by hand or with traditional AutoCAD tools. 

Polylines for Area Delineation 
Benefits of Using Polylines for Area Delineation 

 Familiar, easy to create and edit AutoCAD objects 
 Can be labeled with Civil 3D General Line labels (length, area, elevation, etc) 
 Can be labeled and added to tables using AutoCAD fields 
 Can be created, queried and manipulated through Map tools 
 Can be converted to topologies and Civil 3D parcels with some cleanup 



 
 
  
 
 
Limits of Using Polylines for Area Delineation 

 Not reactive to neighboring polylines 
 Keeps you in AutoCAD mindset 
 Not controlled by Civil 3D object styles 

Recommendations for Use: 

 When you aren’t ready to use Civil 3D parcels to study areas 
 Rational Method Calculations where you want to use an AutoCAD table 
 “Contours” for ponds if you cannot met your design intent with Civil 3D corridors/grading 

objects/surfaces 

Civil 3D Parcels for Area Delineation 
Benefits of Using Parcels for Area Delineation 

 Dynamic with other parcels 
 Easy to make dynamic tables 
 Some custom properties available– like description, Tax ID and address, as well as User 

Defined Properties 
 Area, TaxID, and User Defined Properties can be used in expressions for many calculations 

as part of labels or tables. 
 Flexible, dynamic, autosizing, plan readable labels   
 CAD Standards maintained by Civil 3D Parcel Object Styles 
 Prospector aids in controlling appearance and labeling quickly 
 Prospector information can be copied and pasted into excel for further study  

 

 

 

 

 

Limits of Using Parcels for Area Delineation 

 Must have good understanding of Civil 3D Site Geometry 
 User defined properties are difficult to use and manage 
 Expressions can only calculate based on the current parcel– cannot sum or do “percent of 

the whole” calculations in tables or labels. 
 No intersect topology intelligence (ie cannot blend subcatchments and soils) 
 Cannot be queried or take advantage of other Map tools 



 
 
  
 
 

Recommendations for Use: 

 For subcatchments, soils areas and similar on small sites or when you have already done 
most of the “overlay” breakdown by hand 

 When you want to do the rational method calculations right in your parcel table or area 
labels 

 When the truly dynamic nature of parcels outweighs any negatives  

Map Polygon Topology 
Benefits of Using Topologies for Area Delineation 

 Robust analysis tools for intersection of topologies– ie breakdown of subcatchments 
overlaid with soil group overlaid with cover type 

 Semi-dynamic labeling that “reads” the topology data similar to Civil 3D labels 
 Thematic mapping capabilities for presentation drawings and analysis 
 Can be queried, modified and analyzed using Map tools 
 Works with attribute extraction for semi-dynamic tables with can be used to many 

different types of calculations 
 Information can be reported and exported to drawing tables or external files 



 
 
  
 
 
Limits of Using Topologies for Area Delineation 

 Cannot be used as Civil 3D objects nor easily converted in an intelligent way 
 Often challenging to prepare data property to create a sound topology 
 Map tools are often unfamiliar to Civil 3D/Land Desktop users 

Recommendations for Use: 

 Medium to large sites with several subcatchments, soil groups, cover types and other 
constraints for entering into Rational, TR-55 or TR-20 based modeling programs 

 When you’d like to do TR-55 and composite CN calculations right in your drawing in a 
semi-dynamic way 

 When you’d like to put together themed maps or presentation drawings based on the 
analysis 

Using Civil 3D Parcels for Area Delineation 
Civil 3D parcels can be used to delineation, labeling and analysis of subcatchment, soils 
boundaries and cover. 

Civil 3D parcels interact as site geometry with other Civil 3D objects such as alignments and 
feature lines. 

   

Always be sure to create parcels from lines that formed closed areas with no overlap. Make a 
new site for each parcel type. 

If you were doing all of your SWM area study using Civil 3D Parcels, you should have a site for 
each different type of area such as: 

 Soil Area Site 
 Subcatchment Area Site 
 Cover Type Site 



 
 
  
 
 
Take advantage of the extra fields available in Prospector for additional labeling and study 
capabilities, or add user defined properties.  Also experiment with building custom parcel labels 
and tables to call out your additional information. 

Using Map Topologies for Area Delineation 
Civil 3D parcels can be used to delineation, labeling and analysis of subcatchment, soils 
boundaries and cover. 

This is by far the most powerful analysis tool available to us in the Civil 3D environment.  
(Remember, Civil 3D is built on Map 3D).  It will be important for you to read through the Map 
3D Tutorials on Polygon Topologies, Drawing Cleanup, Object Data and other Map tools. 

This will be difficult to repeat with your own data at first.  Map topologies are rather picky about 
their geometry.  Don’t give up! Go through the tutorials a few times and look for ways you can 
leverage this in your work.  There are many, many uses for topologies. 

 

 

 

 

 

 

Build Your Geometry: Polylines and Centroids 
Start with AutoCAD polylines, and then break at intersection points per topology requirements 
(see Help). Make sure each enclosure has a centroid. Centroids can be blocks, nodes, or text. 
You can manually place centroids, or if you are importing GIS data (such as a shapefile) you 
can use Map>Tools>Create Centroids. 

 

 

 

 

 

 



 
 
  
 
 
Create Three Topologies 
Use Map>Topologies>Create to define your topology. Work through the Wizard picking the 
appropriate geometry to each topology: 

1. Subcatchments 
2. Soil Groups 
3. Cover Types 
 
 
 
 
 
 
 
 

Define Object Data for Your Topologies 
Create the object data tables under Map>Object Data>Define Object Data that will house the 
information to give each polygon intelligence such as soil group, subcatchment number, cover 
type and any other important information.  

 

 

 

 

 

 

 

 

 



 
 
  
 
 
Attach Appropriate Object Data to Each Polygon Centroid 
After you define the object data, use Map>Object Data>Attach/Detach Object Data to attach 
the appropriate data table to each centroid. Use the AutoCAD Properties box to go through and 
assign the correct values to each centroid. 

 

 

 

 

 

 

Create Two Overlay Topologies 
Unfortunately, Map won’t let us to a “three way stack” of our topologies. Make an overlay 
topology that combines Subcatchments with Soil Groups called “Sub_Soil”, then make a second 
overlay topology that combines “Sub_Soil” with Cover Types. 

 

 

 

 

 

 

 

 

Make an Annotation Template For Labeling Each Polygon 
An annotation, not unlike a Civil 3D label, harvests the resulting object data from the final 
overlay topology.  

 

 

 



 
 
  
 
 
Apply a Theme to Your Topology Including Annotation 
Create a theme that separates the topology into its smallest parts. Apply hatch color and 
annotation. 

 

 

 

 

 

 

 

 

 

Create a Data Extraction Table  
Annotations are really just attributed blocks. That attribute information can be extracted as a 
.csv, exported to Excel, or made into an AutoCAD table. Additional columns can be added for 
formulas, user data, fields and more. Also, you can explore the possibilities of creating a 
dynamic link to Excel using the new AutoCAD 2008 tools. 



 
 
  
 
 

Using Polylines for Area Delineation 
Regular polylines can be used for area delineation, and can be labeled with Civil 3D General 
line labels.  



 
 
  
 
 
A Few Ideas for Obtaining Pond Information 
Surfaces>Utilities>Extract Objects from Surface is useful for obtaining polylines that 
represent contours. These contours can then be labeled with a general line label which can 
make it easier to obtain contour areas. This information can now be quickly typed into your 
stormwater modeling software. 

 

 

 

 


